Installer une ChatBox Ajax Blueimp dans votre forum

Dans ce forum, retrouvez des tutoriels divers sur l'utilisation et l'amélioration de votre forum phpBB.

Pour du support rendez-vous sur notre site spécialisé francophone http://www.phpbb-assistance.com

Modérateurs : Administrateurs, Rédacteurs, Modérateurs

Règles du forum
Pour du support rendez-vous sur notre site francophone http://www.phpbb-assistance.com
Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 13 avr. 2011 00:58

Ta bdd est bonne mais revois l'étape 3


Elro
Nouvel inscrit
Nouvel inscrit
Messages : 7
Enregistré le : 09 avril 2011
Système d'exploitation : Windows Seven

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Elro » 14 avr. 2011 12:39

J'ai tout vérifié, toutes les manips sont correctes.

Voici le code dans index_body.html :

Code : Tout sélectionner

<table class="tablebg" width="100%" cellspacing="0">
<tr>
	<td class="cat2" colspan="2"><h4><!-- IF S_DISPLAY_ONLINE_LIST --><!-- IF U_VIEWONLINE -->
	<!-- IF S_IN_GROUP_2 or S_IN_GROUP_4 or S_IN_GROUP_5 -->
<div class="forumbg">
      <div class="inner"><span class="corners-top"><span></span></span>
         <table class="table1" cellspacing="0">
            <thead>
               <tr>
                  <th style="text-align:left;">
                   <a href="http://le.guild-heberg.fr/chat/">
					<font color="#6FFE01">Chatbox</font></a>                   </th>
               </tr>
            </thead>
            <tbody>
               <tr class="bg3";>
                  <td>
					<iframe src="chat/index.php" width=995 height=600></iframe>
                  </td>
               </tr>
            </tbody>
         </table>      
   <span class="corners-bottom"><span></span></span></div>
</div> 
<!-- ENDIF --> 
	<a href="{U_VIEWONLINE}">{L_WHO_IS_ONLINE}</a><!-- ELSE -->{L_WHO_IS_ONLINE}<!-- ENDIF --> -<!-- ENDIF -->&nbsp;{L_STATISTICS}</h4></td>
Et voici a quoi correspond mes rang/id dans ma bdd :

BDD

Il y'a peut être un probléme avec les conditions du code et celle de la bdd.

EDIT : le problème des chiffres est résolu grâce a l'iframe surement, cependant, les utilisateurs du forum ne peuvent pas se connecter avec leur propre mot de passe, ils sont obligés de laisser el champ vide... donc en gros chacun peut prendre un pseudo d'un autre.

je te laisse tester.

Compte : Test
mdp : osashen
forum : Ici

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 14 avr. 2011 13:29

A prt des fichiers ml modifier je ne vois ps trop ce qui peux en être la cause.

Supprime les fichiers du mod et ceux que tu as modifier de ton serveur puis renvoi les comme ça on sera sur que tout y est ensuite vide le cache manuellement et rafraichi les templates


Adek
Membre junior
Membre junior
Messages : 10
Enregistré le : 07 avril 2011
Système d'exploitation : Windows XP - SP3

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Adek » 18 avr. 2011 14:33

Salut Steph,
Je reviens vers toi car depuis l'installation de la chatbox, un membre inscrit qui vit en Espagne à ces lignes qui apparaissent en haut de la page :

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3825: Cannot
> modify header information - headers already sent by (output started at
> /chat/lib/lang/es.php:1)
> [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3827: Cannot
> modify header information - headers already sent by (output started at
> /chat/lib/lang/es.php:1)
> [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3828: Cannot
> modify header information - headers already sent by (output started at
> /chat/lib/lang/es.php:1)
> [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3829: Cannot
> modify header information - headers already sent by (output started at
> /chat/lib/lang/es.php:1)

Dans functions.php, ces lignes correspondent à ça si je ne me trompe pas :

// application/xhtml+xml not used because of IE
header('Content-type: text/html; charset=UTF-8');

header('Cache-Control: private, no-cache="set-cookie"');
header('Expires: 0');
header('Pragma: no-cache');

Aurais tu une idée de modifications à faire pour arranger cela?
Merci.
mon forum : jameshorner.fr/forum.

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 18 avr. 2011 19:12

Salut,

Simplement un souci d'encodage du fichier chat/lib/lang/es.php qui dois être en UTF8 (Sans BOM) ou alors il y a un espace tout en haut du fichier avant le <?php


Adek
Membre junior
Membre junior
Messages : 10
Enregistré le : 07 avril 2011
Système d'exploitation : Windows XP - SP3

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Adek » 18 avr. 2011 19:57

Merci de ta réponse.
Alors j'ai édité puis sauvegarder sans le modifier le fichier avec Notepad ++. Ça suffit pour le problème d'encodage non?
Pour l'espace il n'y en avait pas...

J'ai demandé à mon inscrit espagnol de vérifier si le problème est résolu. Je te tiens au courant. Merci encore.

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 18 avr. 2011 21:24

Adek a écrit :Alors j'ai édité puis sauvegarder sans le modifier le fichier avec Notepad ++. Ça suffit pour le problème d'encodage non?
Non cela ne suffit pas il faut que tu aille dans le menu encodage et que tu convertisse en UTF8


Adek
Membre junior
Membre junior
Messages : 10
Enregistré le : 07 avril 2011
Système d'exploitation : Windows XP - SP3

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Adek » 18 avr. 2011 22:34

Merci Steph.
Qu'est ce que je deviendrais sans toi? :-D

J'ai encodé en UTF8 (sans BOM).

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 18 avr. 2011 22:41

;)


Feleni
Nouvel inscrit
Nouvel inscrit
Messages : 1
Enregistré le : 24 avril 2011
Système d'exploitation : Windows Seven

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Feleni » 24 avr. 2011 15:05

Salut d'abord merci pour ce tutoriel mais j'ai un problème.
J'ai suivi a la lettre ce que tu as écrit mais lorsque je raffraichie et compagnie , le fond et l'alignement de mon thème disparaissent.
Comment faire pour résoudre cela?

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 24 avr. 2011 15:28

Salut et bienvenue,

Tout d'abord vérifie toutes tes modifications il est possible qu'il te manque une balise ouvrante ou fermante.

Ensuite sans lien ni compte de test c’est difficile d'être objectif


Elro
Nouvel inscrit
Nouvel inscrit
Messages : 7
Enregistré le : 09 avril 2011
Système d'exploitation : Windows Seven

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Elro » 29 avr. 2011 22:38

Steph a écrit :A prt des fichiers ml modifier je ne vois ps trop ce qui peux en être la cause.

Supprime les fichiers du mod et ceux que tu as modifier de ton serveur puis renvoi les comme ça on sera sur que tout y est ensuite vide le cache manuellement et rafraichi les templates

J'étais parti en vacance désolé.

ML c'est a dire ??

J'ai tout refait, toujours le, meme soucis. Les mots de passe ne sont pas pris en compte.

Y-a t-il un moyen de connecter un membre directement a la chatbox lorsqu'il est connecté sur le forum?

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 29 avr. 2011 23:25

Elro a écrit :ML c'est a dire ??
Désoler j'ai des souci avec ma touche A ---> Ml = mal :-D
Elro a écrit :J'ai tout refait, toujours le, meme soucis. Les mots de passe ne sont pas pris en compte.
Je pense à l’intégration qui n'est pas bonne mais pourquoi je ne sais pas!
Elro a écrit :Y-a t-il un moyen de connecter un membre directement a la chatbox lorsqu'il est connecté sur le forum?
Si c'est bien modifié c'est le cas par défaut


vodkline
Nouvel inscrit
Nouvel inscrit
Messages : 3
Enregistré le : 29 avril 2011
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par vodkline » 29 avr. 2011 23:51

j'ai suivie le tuto a la lettre mais le nom de ce qui parle s'affiche pas,pouvez vous m'aider

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2791
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 30 avr. 2011 00:00

Salut,

As-tu au moins pris la peine de lire le sujet en entier ?

La réponse s'y trouve déjà

Verrouillé

Retourner vers « Tutoriels phpBB »