Installer une ChatBox Ajax Blueimp dans votre forum

Dans ce forum, retrouvez des tutoriels divers sur l'utilisation et l'amélioration de votre forum phpBB.

Pour du support rendez-vous sur notre site spécialisé francophone http://www.phpbb-assistance.com

Modérateurs : Administrateurs, Modérateurs, Rédacteurs

Règles du forum
Pour du support rendez-vous sur notre site francophone http://www.phpbb-assistance.com
Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2782
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 23 nov. 2010 21:50

Salut,

As-tu rafraichi les templates et le thèmes ?

Vérifie également que tu as bien envoyé tous les fichiers sur le serveur.

Ceci dit cela fonctionnerai mieux sur la dernière version de phpbb

Avatar du membre

Léa
V.I.P
V.I.P
Messages : 356
Enregistré le : 21 janvier 2010
Système d'exploitation : Windows XP - SP3

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Léa » 23 nov. 2010 22:20

Bonjour Jorox ;

penses à aller te présenter ici ;)
Image


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 23 nov. 2010 23:10

Je vais aller me présenter.

J'ai bien vider les caches et rafraichit le template, parcontre je suis en subsilver2, et les fichiers sont un peu différents.

Parcontre quand je modifie le overall_header ou footer avec les lignes de code ssuivantes :

Code : Tout sélectionner

<!-- IF not S_IS_BOT -->
<div style="font-size: 1.2em; margin-bottom: 20px;">{SHOUTBOX}</div>
<!-- ELSE -->
<div id="ajaxChatCopyright"><a href="https://blueimp.net/ajax/">AJAX Chat</a> © <a href="https://blueimp.net">blueimp.net</a></div>
<!-- ENDIF -->
Je vois apparaitre le forum furtivement quand j'envoie un MP à quelqu'un...

Trop bizarre, mais comme je ne connais pas trop le PHP et autre je nage.


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 23 nov. 2010 23:26

Des membres de mon forum m'ont dit qu'ils voyaient apparaître egalement la chatbox furtivement quand ils postaient un message.

Dés que j'ai enlever le code dans overall_footer, et raffraicit le tout, on ne la voyait plus apparaitre lors des MP et messages.

Parcontre aucune trace de la chatbox sur le frontal du site

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2782
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 24 nov. 2010 00:10

C'est celle que l'on utilise ici et logiquement tu devrai obtenir le meme résultat si tu as bien modifié tout ce qu'il faut.

Peux-tu donner l'url de ton forum que je puisse voir ?

Indique nous aussi a qu'elle endroit tu l'a placé


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 24 nov. 2010 06:49

Merci steph pour tes réponses rapides,

mon forum http://cafejeu.free.fr/forum

Mon chat est dans http://cafejeu.free.fr/forum/chat

J'ai mis les fichiers exactement comme dans la procédure.

J'ai modifié le function.php dans /forum/includes/

J'ai modifié le stylesheet.css dans /forum/styles/subsilver2/theme/

J'ai modifié le index_body.html dans /forum/styles/subsilver2/theme/

J'ai également essayé de modifié le overall_footer.html et le overall_header.html dans /forum/styles/subsilver2/theme/ comme dans la procédure de blueimp

Si tu veux je peux peut être te transmettre tous les fichiers modifiés?


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 24 nov. 2010 11:09

j'ai mis à jour mon forum en 3.0.8, j'ai des bugs d'affichages sur 3 élements, c'est bizarre :

{ UNREAD_POSTS }
{ NO_UNREAD_POSTS }
{ SEARCH_UNREAD }

tout le reste est OK, comprends pas

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2782
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 24 nov. 2010 11:45

Ok je regarderai ça quand je rentre.

Par contre pour ta mise a jour c'est des clés de langue qui te manque en rapport a la traduction mais rien a voir avec le mod


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 24 nov. 2010 12:06

Ouais c'est sur que c'est lié à la mise à jour que j'ai faite, et comment on fait pour obtenir ces clés de langue manquantes?

je te remercie c'est sympa


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 24 nov. 2010 12:31

j'ai récupéré un pack de lang FR 3.0.8 j'ai remplacé le miens et tous les bugs ont disparus, merci pour le tuyau


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 24 nov. 2010 18:45

Après la mise à jour j'ai juste refait la modif préconisé par blueimp parce qu'elle est vite rapide à faire:

http://sourceforge.net/apps/mediawiki/a ... ntegration

Et ça me refait comme hier, la shootbox apparait furtivement quand j'envoie un message ou un mp, mais rien sur le frontal.

Donc la j'ai enlevé la modif sur le overall_footer pour l'instant.

On dirait que le overall_footer n'est pas la première page du forum avec subsilver2....


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 25 nov. 2010 12:11

Salut Steph,

est-ce je peux te donner mes fichiers par mail par ex? et tu jettes un coup d'oeil, peut être qu'il y a un truc qui va te sauter aux yeux?

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2782
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 25 nov. 2010 16:38

Salut,

Fait un package zippé puis donne moi le lien après avoir envoyé l'archive sur ton serveur et je regarderai dans la soirée

Avatar du membre

Steph
Administrateur suppléant
Administrateur suppléant
Messages : 2782
Enregistré le : 07 février 2009
Système d'exploitation : Windows XP - SP3
Localisation : Alsace
Contact :

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par Steph » 25 nov. 2010 23:37

J'ai bien reçu ton MP et je pense avoir trouvé ton souci ......... afin je l'éspère.

Tu as mal placé le code suivant dans ton include/fonctions.php

Code : Tout sélectionner

'SHOUTBOX'          => getShoutBoxContent(),
Regarde bien il faut le placer après

Code : Tout sélectionner

	// The following assigns all _common_ variables that may be used at any point in a template.
	$template->assign_vars(array(
@+ ;)


jorox
Membre junior
Membre junior
Messages : 16
Enregistré le : 23 novembre 2010
Système d'exploitation : Windows XP

Re: Installer une ChatBox Ajax Blueimp dans votre forum

Message par jorox » 26 nov. 2010 10:50

Ouais c'est bien ça, jsuis vraiment un mickey! :lol:

Merci beaucoup steph, je vais effectuer tes autres modifs parce que la la shootbox est vraiment vilaine, elle est toute diforme.

Verrouillé
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Tutoriels phpBB »